
Appendix 1 : List of the 587 species of the leaf dataset 
 
Abelia × grandiflora  
Abies alba  
Abies balsamea  
Abies concolor  
Abies grandis  
Abies homolepis  
Abies koreana  
Abies lasiocarpa  
Abies nordmanniana  
Abies pinsapo  
Abies procera  
Abies veitchii  
Acer buergerianum  
Acer campestre  
Acer cappadocicum  
Acer carpinifolium  
Acer caudatum  
Acer circinatum  
Acer coriaceifolium  
Acer davidii  
Acer griseum  
Acer japonicum  
Acer macrophyllum  
Acer mandshuricum  
Acer monspessulanum  
Acer negundo  
Acer opalus  
Acer palmatum  
Acer pensylvanicum  
Acer platanoides  
Acer pseudoplatanus  
Acer rubrum  
Acer rufinerve  
Acer saccharinum  
Acer saccharum  
Acer sempervirens  
Acer tataricum  
Actinidia arguta  
Actinidia deliciosa  
Actinidia kolomikta  
Aesculus × carnea  
Aesculus chinensis  
Aesculus flava  
Aesculus glabra  
Aesculus hippocastanum  
Aesculus × mutabilis  
Aesculus × neglecta  
Aesculus parviflora  
Aesculus pavia  
Aesculus turbinata  
Ailanthus altissima  
Akebia quinata  
Alangium platanifolium  
Allamanda cathartica  
Alnus alnobetula  
Alnus cordata  
Alnus glutinosa  
Alnus incana  
Amelanchier laevis  
Amelanchier lamarckii  
Amelanchier ovalis 
Amelanchier ovalis  
Amelanchier spicata  
Amorpha fruticosa  
Anagyris foetida  
Andrographis paniculata  
Aralia elata  
Araucaria araucana  
Arbutus menziesii  
Arbutus unedo  
Argyrocytisus battandieri  
Aronia arbutifolia  
Aronia prunifolia 
Asparagus acutifolius 
Asparagus acutifolius 
Aucuba japonica  

Berberis anhweiensis  
Berberis aquifolium 
Berberis julianae  
Berberis thunbergii  
Berberis vulgaris  
Betula alba subsp. 
papyrifera 
Betula alleghaniensis  
Betula alnoides  
Betula costata  
Betula dahurica  
Betula ermanii  
Betula insignis  
Betula lenta  
Betula maximowicziana  
Betula nana  
Betula nigra  
Betula pendula  
Betula populifolia  
Betula utilis var. 
jacquemontii 
Bougainvillea glabra  
Bougainvillea spectabilis  
Broussonetia papyrifera  
Brunfelsia pauciflora  
Buddleja × weyeriana  
Buddleja davidii  
Buddleja globosa  
Buxus sempervirens  
Callicarpa dichotoma  
Calycanthus floridus  
Camellia sasanqua  
Campsis radicans  
Cananga odorata  
Caragana arborescens  
Carpenteria californica  
Carpinus betulus  
Carpinus caroliniana  
Carpinus japonica  
Carya illinoinensis  
Carya ovata  
Castanea sativa  
Catalpa bignonioides  
Catalpa ovata  
Ceanothus americanus  
Ceanothus × delilianus  
Cedrus deodara  
Cedrus libani  
Celtis australis  
Celtis occidentalis  
Centratherum punctatum  
Cephalanthus occidentalis  
Cephalaria leucantha 
Cephalaria leucantha 
Cephalotaxus sinensis  
Ceratonia siliqua  
Cercidiphyllum japonicum  
Cercis canadensis  
Cercis chinensis  
Cercis siliquastrum  
Chaenomeles japonica  
Chaenomeles sinensis  
Chaenomeles speciosa  
Chimonanthus praecox  
Chionanthus retusus  
Chionanthus virginicus  
Choisya ternata  
Cinnamomum camphora  
Cinnamomum tenuifolium  
Cistus albidus 
Cistus albidus  
Cistus creticus subsp. 
eriocephalus 
Cistus ladanifer  
Cistus laurifolius  
Cistus salviifolius  

Citrus × aurantium  
Citrus japonica  
Citrus limon  
Citrus trifoliata 
Clematis flammula  
Clematis montana  
Clematis vitalba  
Clematis viticella  
Clerodendrum 
trichotomum  
Clethra alnifolia  
Clinacanthus nutans  
Colutea arborescens  
Coris monspeliensis 
Cornus alba  
Cornus controversa  
Cornus florida  
Cornus kousa  
Cornus mas  
Cornus nuttallii  
Cornus sanguinea  
Cornus sericea  
Coronilla juncea 
Corylopsis spicata  
Corylus avellana  
Corylus colurna  
Corylus maxima  
Cotinus coggygria  
Cotoneaster floccosus  
Cotoneaster frigidus  
Cotoneaster horizontalis  
Cotoneaster integerrimus  
Cotoneaster multiflorus  
Crataegus × lavallei  
Crataegus laevigata  
Crataegus mollis  
Crataegus monogyna  
Crataegus nigra  
Crataegus pedicellata  
Crataegus pinnatifida  
Crataegus sanguinea  
Crataegus succulenta  
Crataemespilus 
grandiflora  
Cryptomeria japonica  
Cunninghamia lanceolata  
Cydonia oblonga  
Cytisus scoparius  
Danae racemosa  
Daphne mezereum  
Dasiphora fruticosa  
Davidia involucrata  
Decaisnea insignis  
Deutzia gracilis  
Deutzia hybrida  
Deutzia longifolia  
Deutzia scabra  
Dillenia suffruticosa  
Diospyros kaki  
Diospyros lotus  
Dipelta floribunda  
Dracaena reflexa  
Dracaena surculosa  
Duranta erecta  
Edgeworthia tomentosa  
Ehretia dicksonii  
Elaeagnus angustifolia  
Elaeagnus pungens  
Elaeagnus rhamnoides 
Elaeagnus × 
submacrophylla  
Elaeagnus umbellata  
Eleutherococcus 
sieboldianus  
Erica arborea  
Erica multiflora 

Eucommia ulmoides  
Euonymus alatus  
Euonymus europaeus  
Euonymus fortunei  
Euonymus sachalinensis  
Euonymus verrucosus  
Euphorbia pulcherrima  
Excoecaria 
cochinchinensis  
Exochorda racemosa 
subsp. giraldii 
Fagus grandifolia  
Fagus orientalis  
Fagus sylvatica  
Fallopia aubertii  
Ficus benjamina  
Ficus carica  
Firmiana simplex  
Flemingia strobilifera  
Forsythia × intermedia  
Frangula alnus  
Fraxinus excelsior  
Fraxinus latifolia  
Fraxinus ornus  
Fraxinus paxiana  
Fumana ericifolia 
Fumana laevipes 
Fumana thymifolia 
Fumana viridis 
Gaultheria procumbens  
Ginkgo biloba  
Gleditsia triacanthos  
Globularia alypum 
Graptophyllum pictum  
Gymnocladus dioica  
Halesia carolina  
Halesia tetraptera var. 
monticola 
Halimodendron 
halodendron  
Hamamelis × intermedia  
Hamamelis virginiana  
Hedera helix  
Helianthemum hirtum 
Helichrysum stoechas 
Heptacodium miconioides  
Hibiscus rosa-sinensis  
Hibiscus syriacus  
Holodiscus discolor  
Hovenia dulcis  
Humulus lupulus  
Hydrangea arborescens  
Hydrangea macrophylla  
Hydrangea paniculata  
Hydrangea petiolaris  
Hydrangea quercifolia  
Hypericum androsaemum  
Ilex aquifolium  
Ilex macrocarpa  
Indigofera tinctoria  
Ixora javanica  
Jasminum nudiflorum  
Juglans nigra  
Juglans regia  
Juniperus communis  
Juniperus phoenicea 
Justicia gendarussa  
Kalopanax septemlobus  
Kerria japonica  
Koelreuteria paniculata  
Kolkwitzia amabilis  
Laburnum alpinum  
Laburnum anagyroides  
Lagerstroemia indica  
Lagunaria patersonia  
Lantana camara  



Lavandula angustifolia  
Lavandula latifolia 
Lavandula stoechas  
Lawsonia inermis  
Ledum palustre  
Ligustrum lucidum  
Ligustrum ovalifolium  
Liquidambar orientalis  
Liquidambar styraciflua  
Liriodendron chinense  
Liriodendron tulipifera  
Lonicera acuminata  
Lonicera caprifolium  
Lonicera × heckrottii  
Lonicera implexa  
Lonicera involucrata  
Lonicera ligustrina var. 
pileata 
Lonicera maackii  
Lonicera nigra  
Lonicera × purpusii  
Lonicera tatarica  
Lonicera xylosteum  
Loropetalum chinense  
Lycium barbatum  
Machilus nanmu 
Maclura pomifera  
Magnolia acuminata  
Magnolia denudata  
Magnolia figo  
Magnolia grandiflora  
Magnolia kobus  
Magnolia liliiflora  
Magnolia obovata  
Magnolia sieboldii  
Magnolia × soulangeana  
Magnolia stellata  
Magnolia tripetala  
Magnolia × wiesneri  
Mahonia bealei  
Malus domestica  
Malus floribunda  
Malus × purpurea  
Malus sargentii  
Malus sylvestris  
Malus toringo  
Malus toringoides  
Malus trilobata  
Malvaviscus arboreus  
Manihot esculenta  
Melastoma malabathricum  
Mentha × piperita  
Mespilus germanica  
Metasequoia 
glyptostroboides  
Morus alba  
Morus nigra  
Murraya paniculata  
Mussaenda erythrophylla  
Mussaenda philippica  
Nerium oleander  
Nothofagus antarctica  
Nyssa sylvatica  
Olea europaea  
Ononis minutissima 
Orthosiphon aristatus  
Osmanthus × burkwoodii  
Osmanthus fragrans  
Ostrya carpinifolia  
Ostrya virginiana  
Oxydendrum arboreum  
Paeonia × suffruticosa  
Parrotia persica  
Parrotiopsis 
jacquemontiana  
Parthenocissus inserta  

Parthenocissus 
quinquefolia  
Parthenocissus 
tricuspidata  
Passiflora caerulea  
Paulownia tomentosa  
Persicaria minor  
Petteria ramentacea  
Phellodendron amurense  
Philadelphus coronarius  
Phillyrea angustifolia  
Photinia × fraseri  
Photinia davidiana  
Phyllanthus myrtifolius  
Phyllostachys edulis  
Physocarpus opulifolius  
Phytolacca dioica  
Picea abies  
Picea asperata  
Picea breweriana  
Picea engelmannii  
Pieris floribunda  
Pinus nigra  
Piper sarmentosum  
Pistacia lentiscus  
Pittosporum tobira  
Platanus hispanica  
Platanus orientalis  
Plumbago auriculata  
Podocarpus macrophyllus  
Polyscias balfouriana  
Populus alba  
Populus balsamifera  
Populus × canescens  
Populus deltoides subsp. 
monilifera 
Populus nigra  
Populus simonii  
Populus tremula  
Prunus armeniaca  
Prunus avium  
Prunus cerasifera  
Prunus cerasus  
Prunus davidiana  
Prunus domestica  
Prunus dulcis  
Prunus fenzliana  
Prunus incana  
Prunus incisa  
Prunus laurocerasus  
Prunus lusitanica  
Prunus maackii  
Prunus mahaleb  
Prunus mume  
Prunus padus  
Prunus persica  
Prunus sargentii  
Prunus serotina  
Prunus serrula  
Prunus serrulata  
Prunus sibirica  
Prunus spinosa  
Prunus subhirtella  
Prunus triloba  
Pseudotsuga menziesii  
Ptelea trifoliata  
Pterocarya pterocarpa  
Pterocarya stenoptera  
Pterostyrax corymbosus  
Punica granatum  
Pyracantha coccinea  
Pyrus betulifolia  
Pyrus calleryana  
Pyrus communis  
Pyrus pyraster  
Pyrus pyrifolia  

Pyrus salicifolia  
Quercus acuminata  
Quercus alba  
Quercus canariensis  
Quercus castaneifolia  
Quercus cerris  
Quercus coccifera 
Quercus coccinea  
Quercus dentata  
Quercus frainetto  
Quercus × hispanica  
Quercus ilex  
Quercus ilicifolia  
Quercus imbricaria  
Quercus libani  
Quercus macranthera  
Quercus macrocarpa  
Quercus marilandica  
Quercus palustris  
Quercus petraea  
Quercus phellos  
Quercus pontica  
Quercus pubescens  
Quercus pyrenaica  
Quercus robur  
Quercus rubra  
Quercus shumardii  
Quercus suber  
Quercus velutina  
Rauvolfia serpentina  
Rhamnus alaternus  
Rhamnus cathartica  
Rhamnus imeretina  
Rhamnus saxatilis  
Rhodomyrtus tomentosa  
Rhodotypos scandens  
Rhus coriaria 
Rhus typhina  
Ribes alpinum  
Ribes aureum  
Ribes rubrum  
Ribes sanguineum  
Ribes uva-crispa  
Ricinus communis  
Robinia hispida  
Robinia luxurians  
Robinia pseudoacacia  
Robinia viscosa  
Rosa canina  
Rosa spinosissima  
Rosmarinus officinalis 
Rubia peregrina 
Rubus idaeus  
Rubus vestitus  
Ruta angustifolia 
Salix alba  
Salix aurita  
Salix babylonica  
Salix caprea  
Salix cinerea  
Salix fragilis  
Salix irrorata  
Salix purpurea  
Salix viminalis  
Sambucus nigra  
Sambucus racemosa  
Sassafras albidum  
Sauropus androgynus  
Schinus molle  
Sciadopitys verticillata  
Sedum anopetalum 
Sedum sediforme 
Sequoia sempervirens  
Shepherdia argentea  
Skimmia japonica  
Smilax aspera  

Sorbaria sorbifolia  
Sorbus alnifolia  
Sorbus aria  
Sorbus aucuparia  
Sorbus domestica  
Sorbus intermedia  
Sorbus torminalis  
Spartium junceum  
Spiraea × billardii  
Spiraea × vanhouttei  
Spiraea japonica  
Spiraea salicifolia  
Spiraea thunbergii  
Stachyurus praecox  
Staehelina dubia 
Staphylea pinnata  
Stewartia pseudocamellia  
Strobilanthes crispa  
Styphnolobium japonicum  
Styrax japonicus  
Symphoricarpos albus  
Symphoricarpos 
orbiculatus  
Syringa josikaea  
Syringa komarowii  
Syringa vulgaris  
Tabernaemontana 
divaricata  
Taxodium distichum  
Taxus baccata  
Tetracera scandens  
Tetradium daniellii  
Thuja occidentalis  
Thuja plicata 
Thujopsis dolabrata  
Thymus vulgaris  
Tibouchina urvilleana  
Tilia americana  
Tilia cordata  
Tilia dasystyla  
Tilia × euchlora  
Tilia × europaea  
Tilia mongolica  
Tilia platyphyllos  
Tilia tomentosa  
Tipuana tipu  
Toona sinensis  
Tsuga canadensis  
Tsuga heterophylla  
Ulmus glabra  
Ulmus laevis  
Ulmus minor  
Ulmus parvifolia  
Ulmus pumila  
Vaccinium myrtillus  
Vaccinium vitis-idaea  
Viburnum × bodnantense  
Viburnum × burkwoodii  
Viburnum davidii  
Viburnum farreri  
Viburnum lantana  
Viburnum lantanoides  
Viburnum lentago  
Viburnum odoratissimum 
var. awabuki 
Viburnum opulus  
Viburnum rhytidophyllum  
Viburnum tinus  
Vinca minor  
Viscum album  
Vitex agnus-castus  
Vitis coignetiae  
Vitis vinifera  
Weigela florida  
Wisteria sinensis 



Appendix 2: Comparative analysis of leaf area measurement methods considering the number of species and leaves used for the validation process, 
the automation level of the method (level 1: image processing requires user adjustments, level 2: image processing is automated but only for one 
file, level 3: image processing is automated on multiple files with a batch process), the measured features (A, P, L, W, C, S referred respectively 
to Area, Perimeter, Length, Width, Circularity and Solidity) and whether or not the software was free. Availability/Reproducibility was set to “No” 
when methodology was incompletely described, complete algorithm not given or software no longer available.  
 

Authors Nb of 
species 

Total nb of 
leaves 

Automation 
level 

Automated analysis tool Features measured Free / 
Not free 

Availability 
Reproducibility 

Current study 587 2218 level 3 FAMeLeS (ImageJ Macro) A, P, L, W, C, S Free Yes 
Igathinathane et al. (2006) 4 12 level 1 Leaf area software A, P, L, W Free No 
Bylesjö et al. (2008) 1 50 level 1 Lamina (software) A, P, L, W, C Free No 
Li et al. (2008) 6 60 level 2 Matlab algorithm (software) A Not free No 
Rico-Garcia et al. (2009) 2 20 level 1 Matlab algorithm (software) A Not free Yes 
Fermat-Diaz et al. (2011) 17 47 level 3 Scanner image methodology (SIM)  A, L, W  Free No 
Patil & Bodhe ((2011) 1 4 level 1 Matlab algorithm (software) A Not free Yes 
Can et al. (2012) 1 15 level 2 OLAT (PHP scripting) A Free No 
Chaudhary et al. (2012) unknown 70 level 2 Matlab algorithm (software) A Not free No 
Jingwen & Hong (2012) unknown 10 level 2 Visual studio algorithm (Snake model) A, P Not free No 
Gong et al. (2013) 3 15 level 1 Software (run on HHD prototype) A Not free No 
Varma & Osuri (2013) 51 100 level 3 Black Spot (software) A Free Yes 
Easlon & Bloom (2014) 1 50 level 1 Easy Leaf Area (Android software) A Free Yes 
Kaiyan (2014) 1 10 level 3 Algorithm (C # language) A Free No 
Karatassiou et al. (2015) 5 240 level 1 Lafore (software) A Free No 
Katabuchi (2015) unknown 100 level 3 LeafArea (R package) A Free Yes 
Jadon et al. (2016) 3 45 level 2 Matlab algorithm (software) A Not free No 
Haqqiman et al. (2016) 3 16 level 1 LAMOS (Visual C++) A Free No 
Amiri & Shabani (2017) 61 61 level 1 ANFIS model (Matlab) A, L, W Not free No 
Drienovsky et al. (2017) 3 30 level 2 Scan LeafArea (software) A Free No 
Schrader et al. (2017) 18 25 level 2 Leaf-IT (Android app.) A Free Yes 
Datta and Chakroboarty (2018) 10 10 level 1 Algorithm (Adobe Photoshop CS) A Not free No 
Tech et al. (2018) 1 20 level 2 USPLeaf (software) A Free No 
Liu et al. (2019) 4 40 level 2 Android app. A, P, L, W Free No 
Siswantoro & Made Artadana (2019) 3 30 level 1 Artificial Neural Network A, P, L, W  No 
Meira et al. (2020) 2 30 level 3 USPLeaf (software) A Free No 
Getman-Pickering et al. (2020) 14 67 level 2 LeafByte (iOS app.) A Free Yes 
Nguyen et al. (2021) 28 28 level 1 Android app. A, P, L, W Free No 
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Appendix 3 : Examples of spectral reflectance of leaf, shadow and background in red, green 
and blue channels of RGB images. On the left, there's a peak corresponding to pixels with 
low reflectance values, representing leaves. On the right, there's another peak with pixels 
having high reflectance values, indicating the white background (and potentially bright 
areas of the leaves). In the intermediate zone, there's a mix of pixels from shadows and 
certain parts of the leaves
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Appendix 4: Step by step procedure to use the macro Fameles 

Step 1: install the freeware Fiji© (or ImageJ©): https://imagej.net/software/fiji/downloads 
 
Step 2:  install the “ResultsToExcel” plugin (https://imagej.net/User:ResultsToExcel) or go to 
Fiji menu: Help->Update->”Manage Update sites” and select ResultsToExcel). This step is 
optional if you don’t want to save your data in an excel file format. 
 
Step 3:  Create on the computer the following four folders to store input pictures (an image file 
can contain one or multiple leaves) and to save the output files generated by the macro (one 
leaf, one output file): 

• 01_ Input_files: copy the RGB files to process into this folder 
• 02_Thumbnails: in this folder, each leaf will be saved as an individual file, even if there 

are multiple leaves in the original image. 
• 03_Leaf_area: here will be saved the files of the final output of the thresholding: black 

leaves on a white background 
• 04_Leaf_perimeter: here will be saved the files of the outline of the leaves (each 

numbered from the top to the bottom of the image, with a continuous numbered across 
files) 

 
Step 4: Download the latest version of the macro: 
(https://doi.org/10.6084/m9.figshare.22354405) 
 
Step 5: open Fiji© (or ImageJ©) and install the macro (Menu Plugins->Macro->Install). An 
alternate method is edit the macro from Fiji (Plugins -> Macro -> Edit) and run. Depending on 
the version of Fiji, an update (menu Help -> Update ImageJ -> Daily build) will be needed to 
have Composite ROIs option in Analyze Particles plugin.  
 
Step 6: When the macro starts, select sequentially (i.e., in the right order) each of the three 
folders when prompted. The macro will run and automatically fill the folders with the 
corresponding files. An Excel file will be automatically generated on the desktop at the end of 
the process, with the default filename “Rename me after writing is done”. Data are stored in 
pixel units. The Count, Label, Area, Perim., Circ., Length, Width and Solidity column headings 
corresponds respectively to the number attributed to the leaf (a unique number for each leaf, 
starting from the upper leaf of the first file and ending with the lower leaf of the last file), the 
file name, leaf area, perimeter, circularity, length, width and solidity. 
 
The circularity index determines how the leaf shape is similar to a circle (Yahiaoui et al. 2012). 
 This index varies between 0 (elongated shapes) and 1 (a circle). 

! = 4π	 × 	Area	
Perimeter!	 

 
The solidity index proposed by Wu et al. (2006) is the ratio between the leaf area and the convex 
hull of the leaf shape. It measures how well the leaf area fits a convex shape and can be 
considered as a proxy of margin undulation.  
 

/ = Area	
Convex	Hull	 
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The scale can be calculated later or implemented in the script if needed (Analyze -> Set Scale). 
However, we highly recommend storing data in pixels to have a backup of raw data since scale 
can differ depending on the way it was calculated (from scanner resolution or with a known 
scanned surface area). 
 
For those who want to check each stage of the processing or may need to troubleshoot, it's 
possible to optionally save the intermediate files created during the image processing. This can 
be done without requiring additional skills. In that case, two additional folders must be created 
to store the intermediate files: 

• 01a_Bandpass_files: the files saved in this folder are obtained from the RGB input files 
after a bandpass filter was applied that creates a halo effect around the leaves to remove 
light shadows 

• 01b_Contrasted_files: here will be saved the files combining the mask and the bandpass 
files to produce a contrasted picture 

 
To allow intermediate savings, edit the script (Menu Plugins->Macro->Edit) and remove the 
symbols /// in front of the corresponding lines before launching the process. 
 
Reference in Appendix 4: 
Yahiaoui, I., Mzoughi, O., & Boujemaa, N. (2012). Leaf Shape Descriptor for Tree Species 

Identification. 2012 IEEE International Conference on Multimedia and Expo, 254–259. 
https://doi.org/10.1109/ICME.2012.130 

Wu, Q., Zhou, C., & Wang, C. (2006). Feature Extraction and Automatic Recognition of Plant 
Leaf Using Artificial Neural Network. Advances in Artificial Intelligence, 3, 5–12. 

 



Appendix 5: 
Spearman correlations between foliar traits values and measurement errors (mean percentage 
of error between estimated and manually measured values). The larger the circle, the stronger 
the correlation. n =  2218. 

 


